Bug #87187

Upgrade wizard ignores step "Update database schema" if an SQL error occurs

Added by Nicole Cordes over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-12-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:

- an upgrade from 7.6.32 to 8.7.21
- an extension with wrong SQL in ext_tables.sql

```
CREATE TABLE tx_foo_domain_model_bar (
fetched boolean DEFAULT '1' NOT NULL,
);
```

Expected:

- an error should be shown anywhere

Actual:

- the step "Update database schema" is silently skipped resulting in a fatal error because of missing l10n_source field in tt_content

#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59182

#2

Updated by Nicole Cordes over 2 years ago

  • Description updated (diff)
#3

Updated by Nicole Cordes over 2 years ago

  • Description updated (diff)
#4

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59182

#5

Updated by Christian Eßl over 1 year ago

  • Category set to Install Tool
#6

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59182

#7

Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63912

#8

Updated by Nicole Cordes over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF