Bug #87215

Mouseover Infobox in page tree shows incorrectly formatted quotation marks (")

Added by Alexander Jaschke almost 3 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-12-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If another user is editing a page a infobox is shown on mouseover. It shows the name of the user in quotation marks. But these are shown as """. See screenshot attached.

TYPO3 9.5.3


Files

Bildschirmfoto 2018-12-19 um 11.45.40.png (11.8 KB) Bildschirmfoto 2018-12-19 um 11.45.40.png Screenshot pagetree / Box shown on mouseover Alexander Jaschke, 2018-12-19 14:53
#1

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from New to Closed

I am no more able to reproduce this issue on 8.7.24, 9.5.5 or 10.0.0-dev (latest master), so I close it.

If you think that this is the wrong decision or experience the issue again,please reopen it or open a new issue with a reference to this one; please add a step-by-step tutorial about how to reproduce the issue.

#2

Updated by Alexander Stehlik 5 months ago

The problem is still valid.

I think you could not reproduce it because the default English labels use single quotes '.

The German translations however use double quotes " which are encoded incorrectly.

So to reproduce the issue you need to install the German language pack or replace the quotes in labels.lockedRecord in the file sysext/core/Resources/Private/Language/locallang_core.xlf with double quotes.

Also available in: Atom PDF