Bug #87399

Wrong default cropping when adding new cropVariant

Added by Richard Haeser 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Image Cropping
Target version:
-
Start date:
2019-01-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Situation:
You have for example a page and in the resources field you have configured 2 cropVariants already. The editors added content and have set their specific crops for all cropVariants.

After a while they decide they want a third cropVariant for the same field. When you add this configuration something strange happens. If you don't open the page properties in the backend, the frontend will correctly render the image with the new cropVariant and will be cropped from the center of the image. But when someone is checking the page properties and for example open the IRRE field for the already added images, the cropping of the new image is based on the first cropVariant instead of the original image. This only occurs with already connected images. When you add a new image, this is working as expected.

Tested and is "wrong" in v8 and v9.

bug_adding_extra_cropvariant.mov (14.8 MB) Richard Haeser, 2019-01-11 10:13

History

#1 Updated by Richard Haeser 2 months ago

Added a video to show the behaviour

#2 Updated by Richard Haeser 2 months ago

  • PHP Version set to 7.2

#3 Updated by Stefanos Karasavvidis 2 months ago

I can confirm this on current master

Also available in: Atom PDF