Bug #87584

Userfields don’t work

Added by Bernhard Eckl about 2 months ago. Updated 29 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2019-01-30
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the documentation (https://docs.typo3.org/typo3cms/extensions/felogin/Configuration/Index.html) is userfields, where you can add fe_users fields as markers. This doesn’t work (only username and name, no matter if defined or not).

History

#1 Updated by Georg Ringer about 1 month ago

  • Status changed from New to Needs Feedback

I can't reproduce that. the markers are alwasys filled in the template, no need to define anything in TS. With TS you can just apply stdwrap stuff to the value.

Example I used

plugin.tx_felogin_pi1 {
userfields {
    zip {
    wrap = a|b
    }
}
}

and the marker ###FEUSER_ZIP###

which markers did you use and are those records also really filled?

#2 Updated by Bernhard Eckl about 1 month ago

  • % Done changed from 0 to 100

I used ###FIRST_NAME### for the first name instead of ###FEUSER_FIRST_NAME### because the marker ###NAME### also works (but it is not in the marker list on top of the template), so I didn’t read the manual completely because of that. When using ###FEUSER_FIRST_NAME### it works.

#3 Updated by Riccardo De Contardi about 1 month ago

@Bernhard Eckl Hi and thank you for your feedback;

If I have not misunderstood you solved your problem and the plugin works as expected, so may we close this issue, or is there still something to do here?

Thank you and best regards.

#4 Updated by Georg Ringer 29 days ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF