Project

General

Profile

Actions

Bug #87764

closed

Bug in building menu configuration in LanguageMenuProcessor

Added by Online Now! GmbH over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-02-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

There is a small bug in building the configuration for the language menu in the class LanguageMenuProcessor ( function prepareConfiguration(), first line ). The merge of the default menu configuration and processor configuration is only done by a simple += operator. This does not work for nested parameters like addQueryString.exclude.

I was not able to set the exclude parameter because of this. The setting gets lost while merging. Its easy to fix with using a merge function which supports nested arrays, like array_merge_recursive().


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #88387: Test does not test the resultClosedAnja Leichsenring2019-05-18

Actions
Related to TYPO3 Core - Bug #88123: menuConfig of LanguageMenuProcessor should be merged with processor configuration in TypoScriptClosed2019-04-09

Actions
Actions #1

Updated by Anja Leichsenring about 5 years ago

  • Related to Bug #88387: Test does not test the result added
Actions #2

Updated by Christian Eßl almost 5 years ago

  • Related to Bug #88123: menuConfig of LanguageMenuProcessor should be merged with processor configuration in TypoScript added
Actions #3

Updated by Christian Eßl almost 5 years ago

This is already fixed with issue #88123.

Actions #4

Updated by Susanne Moog over 4 years ago

  • Status changed from New to Closed

See previous comment.

Actions

Also available in: Atom PDF