Bug #87775

Exceptions thrown for unconfigured login form

Added by Andreas Wolf 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
felogin
Target version:
-
Start date:
2019-02-24
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When adding a new login form to a fresh site, several exceptions are thrown as the redirect URL is null and not a string. The exceptions come from RedirectUrlValidator::isValid().

Steps to reproduce:

  1. create a new site with a basic template
  2. create a folder for users, configure the constant styles.content.loginform.pid with that folder's uid
  3. insert a login form on the start page, w/o any configuration in the flexform
  4. open the start page – boom, you're greeted with an exception

Bonus track: if the constant is not configured, the page is rendered, but the login form shows "oops, an error occurred" because the PID is not configured (as you then can see from the log).

Associated revisions

Revision 9b9c7256 (diff)
Added by Andreas Wolf 9 months ago

[BUGFIX] Ensure redirectUrl is a string

Change-Id: I69837c58e8d31eaa094748c55e27b862d501455c
Resolves: #87775
Releases: master
Reviewed-on: https://review.typo3.org/c/59795
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Frank Naegler <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Benni Mack <>
Reviewed-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review 9 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59795

#2 Updated by Anonymous 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF