Bug #87821

Form Framework has problems with Windows Line Endings

Added by Guido Schmechel over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2019-03-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:
Remote Sprint

Description

Form Framework stops the output of forms when using Windows Line Endings, e.g. due to a faulty upload. The editor gets no indication and the error is hard to find as an integrator.

To prevent this, chr (13) can be removed from the metadata:
https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/form/Classes/Mvc/Persistence/FormPersistenceManager.php#L687

How can you test it?
Just build an simple form yaml config and change the line ending via editor (e.g. PHP Storm) from "LF" to "CRLF"

Also available in: Atom PDF