Bug #87831

Site Language base has no variants

Added by Benni Mack over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Link Handling, Site Handling & Routing
Start date:
2019-03-04
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Feature #86303: Add variants for site's base Closed 2018-09-18
Related to TYPO3 Core - Task #88647: Add missing documentation for language-based base variants Closed 2019-06-27

Associated revisions

Revision a60e226b (diff)
Added by Benni Mack over 1 year ago

[BUGFIX] Streamline base variants for sites

The base variants for site handling was implemented
without taking the site languages into account.

This changes adds the base variants to site
languages as well.

Resolves: #87831
Relates: #86303
Releases: master, 9.5
Change-Id: I2269e8cc8cf1f733cf671de4906c1be765a2b260
Reviewed-on: https://review.typo3.org/c/59838
Tested-by: TYPO3com <>
Tested-by: Nikolaj Wojtkowiak-Pfänder <>
Tested-by: Georg Ringer <>
Tested-by: Benni Mack <>
Reviewed-by: Nikolaj Wojtkowiak-Pfänder <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Benni Mack <>

Revision cbbcf341 (diff)
Added by Benni Mack over 1 year ago

[BUGFIX] Streamline base variants for sites

The base variants for site handling was implemented
without taking the site languages into account.

This changes adds the base variants to site
languages as well.

Resolves: #87831
Relates: #86303
Releases: master, 9.5
Change-Id: I2269e8cc8cf1f733cf671de4906c1be765a2b260
Reviewed-on: https://review.typo3.org/c/59840
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

Revision a3fa9879 (diff)
Added by Benni Mack 11 months ago

[BUGFIX] Add documentation for site-language base variants

Since bugfix #87831 it is possible to also add base variants
for specific languages, however this was not documented.

See

https://review.typo3.org/c/Packages/TYPO3.CMS/+/59840

for the related change.

Related: #87831
Resolves: #88647
Releases: master, 9.5
Change-Id: I9c170fde6a02f98843eddc3388ced90bb1997849
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61162
Tested-by: Björn Jacob <>
Tested-by: TYPO3com <>
Tested-by: Daniel Goerz <>
Reviewed-by: Björn Jacob <>
Reviewed-by: Daniel Goerz <>

Revision 9b6936a5 (diff)
Added by Benni Mack 11 months ago

[BUGFIX] Add documentation for site-language base variants

Since bugfix #87831 it is possible to also add base variants
for specific languages, however this was not documented.

See

https://review.typo3.org/c/Packages/TYPO3.CMS/+/59840

for the related change.

Related: #87831
Resolves: #88647
Releases: master, 9.5
Change-Id: I9c170fde6a02f98843eddc3388ced90bb1997849
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61172
Tested-by: TYPO3com <>
Tested-by: Daniel Goerz <>
Reviewed-by: Daniel Goerz <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59838

#2 Updated by Benni Mack over 1 year ago

#3 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59840

#4 Updated by Benni Mack over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

#6 Updated by Benni Mack 11 months ago

  • Related to Task #88647: Add missing documentation for language-based base variants added

Also available in: Atom PDF