Bug #87985

Permission issue on root page for non-admins on multilanguage environment

Added by Mikel Wohlschlegel about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2019-03-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There seems to be a bug, when a non-admin user edits the page properties of the root page if there is more than one language.

Error message when trying to save root page properties (on all languages):

1: Attempt to modify record 'title of page' (pages:36) without permission. Or non-existing page.

Page with ID 36 is the translation of the page with id 1.

All other pages can be edited.

To reproduce:

  • Multiple languages
  • One backend user group, DB mount set to root page (1)
  • One backend user, no admin user, assigned to this group
  • Access to all pages set correctly in access module
  • Open page properties of root page (wether default language or any translation of it) and try to save --> error

This error does only appear on the root page. All other pages are OK.
The permissions in the database seems to be correct.

Permissions in database seem to be correct (same for all pages):

perms_userid = 1 || perms_groupid = 1 || perms_user = 31 || perms_group = 27 || perms_everybody = 0

TYPO3 version: 9.5.5
PHP 7.2


Files

error.png (20.1 KB) error.png Mikel Wohlschlegel, 2019-03-22 16:40
mountpoint.png (56.7 KB) mountpoint.png Mikel Wohlschlegel, 2019-03-22 16:40
permissions.png (30.4 KB) permissions.png Mikel Wohlschlegel, 2019-03-22 16:40

Related issues

Related to TYPO3 Core - Bug #87165: \TYPO3\CMS\Core\Authentication\BackendUserAuthentication::isInWebMount does not work for translations of web mounts for non admin usersClosedAlexander Bohndorf2018-12-14

Actions
Related to TYPO3 Core - Bug #88321: Permission Problem with Localizied MountpointClosed2019-05-09

Actions
Is duplicate of TYPO3 Core - Bug #87223: Translated root-page record of BE-User cannot be edited/saved (missing webmount)Closed2018-12-19

Actions
#1

Updated by Riccardo De Contardi about 2 years ago

Is this one the same issue? #87223

#2

Updated by Mikel Wohlschlegel about 2 years ago

Yes, indeed it is. Sorry, I didn't see this. You can mark as duplicate.

#3

Updated by Riccardo De Contardi about 2 years ago

  • Related to Bug #87223: Translated root-page record of BE-User cannot be edited/saved (missing webmount) added
#4

Updated by Riccardo De Contardi about 2 years ago

  • Related to deleted (Bug #87223: Translated root-page record of BE-User cannot be edited/saved (missing webmount))
#5

Updated by Riccardo De Contardi about 2 years ago

  • Is duplicate of Bug #87223: Translated root-page record of BE-User cannot be edited/saved (missing webmount) added
#6

Updated by Riccardo De Contardi about 2 years ago

  • Status changed from New to Closed

@Mikel Wohlschlegel thank you for your quick answer; no need to be sorry.

I add your issue as related to the other one to keep track of it;

if you think that closing it is the wrong decision please reopen it or ping me and I'll do.

#7

Updated by Gerrit Code Review about 2 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60407

#8

Updated by Riccardo De Contardi about 2 years ago

  • Category set to DataHandler aka TCEmain
#9

Updated by Riccardo De Contardi about 2 years ago

  • Related to Bug #87165: \TYPO3\CMS\Core\Authentication\BackendUserAuthentication::isInWebMount does not work for translations of web mounts for non admin users added
#10

Updated by Gerrit Code Review about 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59159

#11

Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59159

#12

Updated by Gerrit Code Review almost 2 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59159

#13

Updated by Gerrit Code Review almost 2 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59159

#14

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61253

#15

Updated by Alexander Bohndorf almost 2 years ago

  • Status changed from Under Review to Resolved
#16

Updated by Christian Eßl over 1 year ago

  • Related to Bug #88321: Permission Problem with Localizied Mountpoint added
#17

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF