Project

General

Profile

Actions

Bug #88007

closed

Proxy class SaltedPasswordsService should be SaltedPasswordService

Added by S P over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2019-03-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The proxy class for the deprecated SaltedPasswordService is pluraled to SaltedPasswordsService and thus if used crashes to a fatal error instead of throwing a deprecation notice as intended.

This

namespace TYPO3\CMS\Saltedpasswords {
    class SaltedPasswordsService extends \TYPO3\CMS\Core\Crypto\PasswordHashing\SaltedPasswordService
    {
    }
}

should be
namespace TYPO3\CMS\Saltedpasswords {
    class SaltedPasswordService extends \TYPO3\CMS\Core\Crypto\PasswordHashing\SaltedPasswordService
    {
    }
}

Actions

Also available in: Atom PDF