Bug #88047

GalleryProcessor PDF dimensions

Added by Riny van Tiggelen about 2 months ago. Updated 18 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-04-01
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have a PDF, there is no width and height available in the metadata dimensions.
If you use the GalleryProcessor without options it uses 0 as dimension, which causes the PDF to not be resized.
I think this can be easily solved by checking if the width of the fileObject is above 0, if not use the maxWidth.

Associated revisions

Revision 072e6f62 (diff)
Added by Riny van Tiggelen about 2 months ago

[BUGFIX] Check if fileObject width is greater than 0, if not use maxWidth

If you want to use a PDF inside the GalleryProcessor, the mediaWidth is
always 0, because there are no dimensions in the metadata. This fix
will use the maxMediaWidth if the dimension is not greater than 0.

Resolves: #88047
Releases: master, 9.5
Change-Id: I56a2dc2a946385931172c86e54711ba8aa3f6637
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60357
Tested-by: TYPO3com <>
Tested-by: Koen Wouters <>
Tested-by: Richard Haeser <>
Reviewed-by: Frans Saris <>
Reviewed-by: Koen Wouters <>
Reviewed-by: Richard Haeser <>

Revision f3986608 (diff)
Added by Riny van Tiggelen about 2 months ago

[BUGFIX] Check if fileObject width is greater than 0, if not use maxWidth

If you want to use a PDF inside the GalleryProcessor, the mediaWidth is
always 0, because there are no dimensions in the metadata. This fix
will use the maxMediaWidth if the dimension is not greater than 0.

Resolves: #88047
Releases: master, 9.5
Change-Id: I56a2dc2a946385931172c86e54711ba8aa3f6637
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60360
Tested-by: Riny van Tiggelen <>
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Richard Haeser <>

History

#1 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60357

#2 Updated by Riccardo De Contardi about 2 months ago

Is this issue related or even the same? #83374

#3 Updated by Gerrit Code Review about 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60360

#4 Updated by Riny van Tiggelen about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 18 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF