Bug #88190

Scheduler not running when php_sapi_name is cgi-fcgi

Added by Christian Ebert 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-04-23
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Was discovered in Typo3 8.7.24

- php_sapi_name() on the system reports 'cgi-fcgi'
- \typo3\sysext\core\Classes\Console\CommandApplication.php::97 checks for: if (php_sapi_name() !== 'cli') {

=> The check should be: if (substr(php_sapi_name(), 0, 3) !== 'cgi') {
=> similar to typo3\sysext\backend\Classes\Console\Application.php::99

History

#1 Updated by Bastian Bringenberg 4 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • TYPO3 Version set to 8

Changed Project.

#2 Updated by Christian Ebert 4 months ago

Please close the issue. I think the problem is the hosting environment not providing the php-cli correctly.

Ebert no-lastname-given wrote:

Was discovered in Typo3 8.7.24

- php_sapi_name() on the system reports 'cgi-fcgi'
- \typo3\sysext\core\Classes\Console\CommandApplication.php::97 checks for: if (php_sapi_name() !== 'cli') {

=> The check should be: if (substr(php_sapi_name(), 0, 3) !== 'cgi') {
=> similar to typo3\sysext\backend\Classes\Console\Application.php::99

#3 Updated by Georg Ringer 4 months ago

  • Status changed from New to Closed

closed as requested

#4 Updated by Hartmut Steglich 3 months ago

... the problem is the hosting environment not providing the php-cli correctly.

I can confirm this for the German hoster strato.de which uses "cgi-fcgi" and TYPO3 9.5

Also available in: Atom PDF