Bug #88207

SoftReferenceIndex is missing support for t3://file uri

Added by Jan Delius 9 months ago. Updated 26 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2019-04-25
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The class TYPO3\CMS\Core\Database\SoftReferenceIndex does not check for the "new" typolink syntax with protocol t3 for file references inside the function getTypoLinkParts. Only the old syntax "file:<uid>" is checked.

As a result, the softref links did not increase the number of references in the file list.


Related issues

Related to TYPO3 Core - Bug #80082: Linking to files using the link wizard does not store a reference to the file Closed 2017-03-01
Related to TYPO3 Core - Bug #87652: SoftReferenceIndex :: TypoLink :: links like "t3:// FileLinks" won't be recognized Closed 2019-02-05
Related to TYPO3 Core - Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndex Closed 2018-02-22

Associated revisions

Revision 75aa958b (diff)
Added by Nicole Cordes 2 months ago

[BUGFIX] Streamline SoftReferenceIndex references

This patch streamlines the return values for softref type typoscript and typoscript_tag. Furthermore tests for the API method findRef() are added to ensure same return results.

Furthermore a non-reachable part in findRef_typolink_tag is removed. As the incoming content is split by <a> tags, the <LINK> tag condition within this function will be never fulfilled.

Resolves: #88207
Related: #87652
Releases: master, 9.5
Change-Id: Ifca40c5d0e049c5b5d92a507a9d5ec0249e9953e
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62196
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Georg Ringer <>
Reviewed-by: Benni Mack <>
Reviewed-by: Georg Ringer <>

Revision bee275c3 (diff)
Added by Nicole Cordes 2 months ago

[BUGFIX] Streamline SoftReferenceIndex references

This patch streamlines the return values for softref type typoscript and typoscript_tag. Furthermore tests for the API method findRef() are added to ensure same return results.

Furthermore a non-reachable part in findRef_typolink_tag is removed. As the incoming content is split by <a> tags, the <LINK> tag condition within this function will be never fulfilled.

Resolves: #88207
Related: #87652
Releases: master, 9.5
Change-Id: Ifca40c5d0e049c5b5d92a507a9d5ec0249e9953e
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62205
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Markus Bachmann 6 months ago

@all This bug occurs also in the latest 8.7 version.

#2 Updated by Markus Bachmann 6 months ago

  • Related to Bug #80082: Linking to files using the link wizard does not store a reference to the file added

#3 Updated by Riccardo De Contardi 5 months ago

  • Category set to File Abstraction Layer (FAL)

#4 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62004

#5 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62004

#6 Updated by Gerrit Code Review 3 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62004

#7 Updated by Benni Mack 3 months ago

  • Related to Bug #87652: SoftReferenceIndex :: TypoLink :: links like "t3:// FileLinks" won't be recognized added

#8 Updated by Benni Mack 3 months ago

  • Related to Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndex added

#9 Updated by Gerrit Code Review 2 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62196

#10 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62205

#11 Updated by Nicole Cordes 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack 26 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF