Project

General

Profile

Actions

Bug #80082

closed

Linking to files using the link wizard does not store a reference to the file

Added by Rens Admiraal over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-03-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It seems like there are problems with linking to images from within the RTE. It seems to be related to https://forge.typo3.org/issues/77866 but that report is about inline images, a similar problem occurs with linking to files using the link wizard.

Short problem: no reference to the file is stored so it can still be removed from the filelist while a link exists. When the file is removed this leads to a fatal error "No file found for given UID: 1". This already occurs while editing in the backend so there's no way for the editor to get back to a working state.

Steps to reproduce:
- Clean install of TYPO3 8.6.1
- Upload a file
- Create a page with a text element
- Create a link to the file using the link wizard in the RTE
- Delete the file in the filelist
- Open the page again in the page module, and enjoy the "Oops" screen ;-)

I could reproduce with both rtehtmlarea and ckeditor.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #80086: Avoid exception if linked file is not available anymoreClosedGeorg Ringer2017-03-01

Actions
Related to TYPO3 Core - Bug #88207: SoftReferenceIndex is missing support for t3://file uriClosed2019-04-25

Actions
Actions #1

Updated by Benni Mack over 7 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Accepted
  • Target version set to 8 LTS

Hey Rens,

yup. that's probably related to the soft reference index, where links to files are stored. However, this is still not correct, needs to be fixed - will probably touch this area next week.

Main steps to do:
- Ensure that softref=link is set to all inputLinkType fields via TcaMigration.
- Ensure that softref tracks the new link t3://file syntax.
- Ensure that softref is checked as well when deleting a file.

Actions #2

Updated by Georg Ringer over 7 years ago

I will take care about the exception with #80086 as I introduced that

Actions #3

Updated by Mona Muzaffar about 7 years ago

  • Status changed from Accepted to Resolved

Since Georg has resolved this issue (see related patch), i am going to close this ticket.

Actions #4

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions #5

Updated by Markus Bachmann almost 5 years ago

  • Related to Bug #88207: SoftReferenceIndex is missing support for t3://file uri added
Actions

Also available in: Atom PDF