Bug #88229

levelmedia: -1,slide does not work / is buggy when using Redis for cache_rootline

Added by Bernhard Eckl over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2019-04-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have header images from the page resources. And I configured Redis for cache_rootline like this:

$GLOBALS['TYPO3_CONF_VARS']['SYS']['caching']['cacheConfigurations']['cache_rootline']['backend'] = 'TYPO3\\CMS\\Core\\Cache\\Backend\\RedisBackend';
$GLOBALS['TYPO3_CONF_VARS']['SYS']['caching']['cacheConfigurations']['cache_rootline']['options'] = array('defaultLifetime' => 86400, 'database' => 5, 'persistentConnection' => true);

But then levelmedia: -1,slide does not work right anymore.

#1

Updated by Susanne Moog 9 months ago

  • Status changed from New to Needs Feedback

Tested with the following configuration:

TypoScript (taken from the official docs ;)):

 20 = FILES
 20 {
    references {
        data = levelmedia: -1, slide
    }

    renderObj = IMAGE
    renderObj {
        file.import.dataWrap = {file:current:storage}:{file:current:identifier}
        altText.data = file:current:title
    }
   }

Cache:

                'rootline' => [
                    'backend' => 'TYPO3\\CMS\\Core\\Cache\\Backend\\RedisBackend',
                    'options' => [
                        'database' => 6,
                        'hostname' => 'redis',
                    ],
                ],

I don't get any errors and levelmedia is working fine (and sliding correctly)

#2

Updated by Benni Mack 7 months ago

Same here, Bernhard,

we use Redis Caching for a VERY long time, and never ran into this? Is it possible that your redis cache removes the cache entries because of too small redis cache pool?

#3

Updated by Bernhard Eckl 7 months ago

I just checked my config, it seems that I meanwhile switched to APCU-Cache (I forgot that), it seems that it has faster page generation times than Redis (can you confirm this?).

#4

Updated by Benni Mack 6 months ago

  • Status changed from Needs Feedback to Closed

Bernhard Eckl wrote:

I just checked my config, it seems that I meanwhile switched to APCU-Cache (I forgot that), it seems that it has faster page generation times than Redis (can you confirm this?).

Depends on the use-case: APCU has some limitations in terms of RAM (as you cannot distribute the cache to another server), but if that's fine for you, I recommend you continue working with APCU.

We had misconfigurations with Redis in the past where the Redis cache wasn't large enough, so this might be helpful for somebody else to read this issue in the future!

Also available in: Atom PDF