Bug #88313

Language pack management not working with Typo3 V9

Added by Florian Rival 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Language Manager (backend)
Target version:
-
Start date:
2019-05-09
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

There is a problem with language management module, I can't update extension's languages.

When I add a new language, the translation status for all extension show a list of columns with an update icon on the top instead of only one column for each language (look at file attached) and even if you click on an update icon, there's no language pack downloaded.

Florian

Language pack.jpg View (167 KB) Florian Rival, 2019-05-09 09:16

History

#1 Updated by Florian Rival 6 months ago

Precision : the site was updated from V6.2 to v9

#2 Updated by Andreas Fernandez 6 months ago

  • Status changed from New to Needs Feedback

Can you please check how your EXTCONF/lang/availableLanguages array of your LocalConfiguration.php looks like? Back in 6.2, in some earlier versions the array contained empty values that might interfere now.

#3 Updated by Florian Rival 6 months ago

  • % Done changed from 0 to 100

You are right, the EXTCONF/lang/availableLanguages array was filled with empty values, I removed all empty values and now it works.

Information for all who upgrade from an older Typo3 version to V9 : the folder typo3conf/l10n/ can be removed, it's not used anymore, the new one is var/labels/.

#4 Updated by Susanne Moog 6 months ago

  • Status changed from Needs Feedback to Closed

Thanks for the feedback and the upgrade hint! Closing here for now.

Also available in: Atom PDF