Bug #88350

Image manipulation does not work

Added by Valentin Nedkov (sunman) about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Image Cropping
Start date:
2019-05-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using of image manipulation in the BE does not deliver the desired result in FE.

There is a missing property getter in FileReference. Check the attached file with the modification.


Files

FileReference.php (15.1 KB) FileReference.php Valentin Nedkov (sunman), 2019-05-14 14:31
#1

Updated by Valentin Nedkov (sunman) about 2 years ago

  • Priority changed from Should have to Must have

Attached file contains the fix.

#2

Updated by Frans Saris about 2 years ago

What are you exactly missing you can not access through getProperties()?

#3

Updated by Valentin Nedkov (sunman) about 2 years ago

You're rigth. It is possible to get "crop" from getProperties. It was just more intuitive to get it directly but I have to say that we can stay with that.

#4

Updated by Frans Saris about 2 years ago

There are only a few fields directly accessible through getter methods. The rest of the sys_file_reference record you can access through the getProperties() method.

Think that's enough as you can easily add more properties to your sys_file_reference and there are also not accessible through direct getter methods but are through getProperties().

#5

Updated by Georg Ringer about 2 years ago

  • Status changed from New to Rejected

Closing because no change is required

Also available in: Atom PDF