Bug #88384

IRRE records in BE forms cannot be loaded (unfolded)

Added by Martin R. Krause over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2019-05-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

An IRRE record in a BE form always only shows

"[] 0"

when unfolded. Those IRRE that are open on load work fine.

The ajax request to /ajax/record/inline/expandcollapse appears to respond with an empty result or is misconfigured.

Happens since 9.5.6, did not happen in 9.5.5.


Files

#1

Updated by Andreas Fernandez over 1 year ago

  • Status changed from New to Needs Feedback

Hi,

I fail to reproduce your issue. Please check whether an update to TYPO3 9.5.7 solves your issue.
Please also check whether this may get caused by third party extensions.

Can you spot any errors in your PHP error log?

Kind regards
Andreas

#2

Updated by Martin R. Krause over 1 year ago

TYPO3 9.5.7 update fixed the issue for me.

#3

Updated by Georg Ringer over 1 year ago

  • Status changed from Needs Feedback to Closed

closing issue as solved in 9.5.7

#4

Updated by Niels Langlotz about 1 year ago

In version 9.5.10 the problem persists.

#5

Updated by Tobias Pinnekamp 6 months ago

We currently have the same problem with
- TYPO 9.5.19
- PHP 7.3.18
- MySQL 5.5.5

It only happens on our live server, not on local virtual development machines. Same T3 version, same MySQL version but PHP 7.3.17.

The failing Ajax request has the following parameters:

&ajax[0]=data-43-tt_content-92-image-sys_file_reference-30&ajax[1]=30&ajax[2]=

The same Ajax request in local virtual machine looks like follows:

&ajax[0]=data-43-tt_content-92-image-sys_file_reference-30&ajax[context]=%7B%22config%22%3A%22%7B%5C%22type%5C%22%3A%5C%22inline%5C%2..........e6ea18ee%22%7D

I've shorten the example but the obvious difference is the missing [context] value in the failing request I guess. &ajax[1]=30&ajax[2]= parameters are not present in the working request.

Also available in: Atom PDF