Task #88494

Drop DB field t3_origuid / "origUid" functionality

Added by Oliver Hader 5 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-06-05
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

The special TCA value / DB field "origUid" (usually "t3_origuid") has
had a long run, and it was used for various places, making the
value of the data very ambiguous, non-predictable and thus,
not usable for further usages.

One usage was to copy a record, where origUid contained the value of
the original record - without further evaluation.

Since localizations ("localize" and "copy into language") internally
are using previously mentioned copy process, origUid contained the
value of the original translation - however not very reliable since
consecutive localize & copy processes did not maintain integrity in a
proper way. That's the reason why "translationSource" ("l10n_source")
has been introduced with TYPO3 v8 already.

Additionally, versioning used it to store the original "online ID"
which is contained within "t3ver_oid" as well.

Using the field in any extension for further usage is not recommended,
as it was never clear what the meaning of the value was.

Since the versioning/workspaces and translation handling
implemented properly, this field is filled, but has no real
use anymore - it is now removed.


Subtasks

Task #88495: Drop t3_origuid fields from functional testsClosed

Task #88501: Revert dropping t3_origuid from functional testsClosed

Associated revisions

Revision 55f7beae (diff)
Added by Oliver Hader 5 months ago

[TASK] Drop t3_origuid fields from functional tests

In order to drop t3_origuid semantics (see issue #88494) according
usages should be purged from functional tests. This way functional
changes are easier to spot having to dedicated change-sets.

Resolves: #88495
Releases: master
Change-Id: Ic54efe30bb112b179a176681a3bb067de1791d44
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60880
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Tested-by: Benni Mack <>
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Benni Mack <>

Revision d38fee08 (diff)
Added by Oliver Hader 5 months ago

Revert "[TASK] Drop t3_origuid fields from functional tests"

This reverts commit 55f7beae9e8360c56f9f788774177d7572bbd901.

Unfortunately it's not possible to get rid of t3_origuid completely
without introducing new side-effects. Remaining test adjustments for
#88494 have shown that non-translatable entities used as reference
would rather be deleted & re-created instead of synchronized.

t3_origuid did a good job there - dropping it would introduce the
mentioned regression. Misusing l10n_source for a non-translatable
table sounds as stupid as introducing a new field like sync_origuid.

Related: #88494
Reverts: #88495
Resolves: #88501
Releases: master
Change-Id: I4de8a0cbac1b7c9825991794830efaa53f270709
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60888
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60870

#2 Updated by Oliver Hader 5 months ago

reverted functional test changes - see #88501 for details

#3 Updated by Andreas Fernandez 2 months ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF