Bug #88542

Image size not correct

Added by Daniel Corn over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2019-06-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

A file uploaded through the TYPO3 backend has wrong image dimensions stored in the meta data.

The original file was a TIFF file with size 6000x4000. It has been downsized by Photoshop and exported as JPEG.

Inside the File List the original dimensions (6000x4000) are shown (see "File List screenshot").

Impact

Image Crop does not work correctly and produces misplaced images

`file` command

file .../test-image.jpg
.../test-image.jpg: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=17, height=4000, bps=218, PhotometricIntepretation=RGB, description=                               , manufacturer=SONY, model=ILCE-6400, orientation=upper-left, width=6000], baseline, precision 8, 1700x1133, frames 3

GraphicsMagick

gm identify -debug events .../test-image.jpg
.../test-image.jpg JPEG 1700x1133+0+0 DirectClass 8-bit 165.7Ki 0.000u 0m:0.000003s

Files

file-list-screenshot.png (209 KB) file-list-screenshot.png File List screenshot Daniel Corn, 2019-06-12 10:55
test-image-2.jpg (166 KB) test-image-2.jpg Daniel Corn, 2019-06-12 10:57
#1

Updated by Georg Ringer 9 months ago

  • Status changed from New to Needs Feedback

I tested that on current 10.4 master and latest 9.5.14 and it works fine on both. can you pls recheck on a clean installation?

#2

Updated by Daniel Corn 9 months ago

Thank you for looking into it.

I couldn't reproduce it in another installation too.

Can be closed. Sorry for bothering.

#3

Updated by Bjoern Jacob 9 months ago

  • Status changed from Needs Feedback to Closed

No problem at all. Thanks for your fast reply. Closing as requested by the author.

Also available in: Atom PDF