Bug #88692

Feature #88643: Replace SwiftMailer with Symfony/Mailer

SendCommandTest is skipped due to a warning since symfony/mailer merge

Added by Benjamin Franzke 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Start date:
2019-07-05
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The test still tries to use Swift_Spool classes which are no longer available.
Therefore the test skips with a warning:

1) TYPO3\CMS\Core\Tests\Unit\Command\SendEmailCommandTest::executeWillFlushTheQueue
Trying to configure method "flushQueue" which cannot be configured because it does
not exist, has not been specified, is final, or is static

Associated revisions

Revision 3b8a6dbc (diff)
Added by Benjamin Franzke 5 months ago

[BUGFIX] Adapt SendEmailCommandTest for symfony/mailer

The tests produced a warning which didn't cause CI to abort,
but the test was actually skipped:

1) TYPO3\CMS\Core\Tests\Unit\Command\SendEmailCommandTest
::executeWillFlushTheQueue
Trying to configure method "flushQueue" which cannot be configured
because it does not exist, has not been specified, is final, or is
static

Resolves: #88692
Related: #88643
Releases: master
Change-Id: I3077a011e19050986585e9c788f5db03d18595d3
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61233
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Alexander Schnitzler <>
Tested-by: Benjamin Franzke <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Alexander Schnitzler <>
Reviewed-by: Benjamin Franzke <>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61233

#2 Updated by Benjamin Franzke 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF