Feature #88731

Improve user experience for ajax request in the list module

Added by Oliver Bartsch 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-07-11
Due date:
% Done:

100%

PHP Version:
7.2
Tags:
backend, list module, ux, user experience, user interface
Complexity:
Sprint Focus:

Description

Recently some editors were affected by an improvable user experience in the list module.

If one clicks a button on a record row, which triggers an ajax request, multiple times, the request of course gets executed multiple times. This is very bad behaviour. In the specific case an editor wanted to localize a record by clicking the flag button in the record row. Because the default record had many relations the operation took some time. The editor didn't get feedback for the running operation. This is why he clicks the button again and again. This leds to a couple of errors:
  • huge number of duplicated relations within the localized record
  • multiple error messages e.g. "Translation for record X already exists"
  • lose the possibility to edit the record because of his many relations (Timeout on opening the record)

Surely this is not a bug, but bad user experience.

Therefor I would suggest some feedback for the editor like a "loading spinner" while the operation is ongoing or simply disabling the button after it was clicked once to protect the editor from performing the same operation multiple times.


Related issues

Related to TYPO3 Core - Story #82206: list module enhancements/bugfixes New 2005-07-21

Associated revisions

Revision a6e009e8 (diff)
Added by Oliver Bartsch 3 months ago

[BUGFIX] Disable localization button after initial click

This prevents various errors, caused by clicking the
localization button in the recordlist multiple times.

Resolves: #88731
Releases: master, 9.5
Change-Id: I93499d3892b9897038f8cfbd5f6dab33dc585bb1
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61411
Tested-by: Josef Glatz <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Andreas Fernandez <>

Revision a02211f7 (diff)
Added by Oliver Bartsch 3 months ago

[BUGFIX] Disable localization button after initial click

This prevents various errors, caused by clicking the
localization button in the recordlist multiple times.

Resolves: #88731
Releases: master, 9.5
Change-Id: I93499d3892b9897038f8cfbd5f6dab33dc585bb1
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61420
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Daniel Windloff 4 months ago

  • Related to Story #82206: list module enhancements/bugfixes added

#2 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61411

#3 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61411

#4 Updated by Gerrit Code Review 3 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61411

#5 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61420

#6 Updated by Oliver Bartsch 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF