Bug #88737

Inputlink field shows wrong explanation after update

Added by Dieter Porth 4 months ago. Updated 13 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2019-07-12
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
7.2
Tags:
CodingNight
Complexity:
Is Regression:
Sprint Focus:

Description

Given:
A Content-element shows the name '/Congratulations/Features/[81]" in the field header_link. After toggling you see "t3://page?uid=81".
When :
You change the link and select "t3://page?uid=80".
Then:
The Content-element shows the old(!), wrong name '/Congratulations/Features/[81]" in the field header_link. After toggling you see youre selected "t3://page?uid=80". After saving the content-element you see the new name "/Congratulations/Customize/[80]"
Expected :
After the selection the new link the new name ""/Congratulations/Customize/[80]" should be shown for the selected value "t3://page?uid=80".

Associated revisions

Revision c13aa8be (diff)
Added by Michael Straschek 13 days ago

[BUGFIX] Deactivate link element's explanation toggle after change

Dynamically fetching/applying additional data for the link explanation
seems to be overdone, so we simply deactivate the toggle button and
remove the icon after selection/modification of the link target.
After persisting the record, the updated link explanation
will be visible.

Resolves: #88737
Releases: master, 9.5
Change-Id: I679abb2178aedfc8a29cccace99950a3a8acaab6
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422
Tested-by: Oliver Bartsch <>
Tested-by: Alexander Stehlik <>
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Alexander Stehlik <>
Reviewed-by: Susanne Moog <>

Revision 2a499357 (diff)
Added by Michael Straschek 13 days ago

[BUGFIX] Deactivate link element's explanation toggle after change

Dynamically fetching/applying additional data for the link explanation
seems to be overdone, so we simply deactivate the toggle button and
remove the icon after selection/modification of the link target.
After persisting the record, the updated link explanation
will be visible.

Resolves: #88737
Releases: master, 9.5
Change-Id: I679abb2178aedfc8a29cccace99950a3a8acaab6
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62262
Tested-by: Oliver Bartsch <>
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Susanne Moog 4 months ago

  • Tags set to CodingNight

#2 Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#3 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#4 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#5 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#6 Updated by Gerrit Code Review about 1 month ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#7 Updated by Gerrit Code Review about 1 month ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#8 Updated by Gerrit Code Review 28 days ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#9 Updated by Gerrit Code Review 25 days ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61422

#10 Updated by Oliver Bartsch 25 days ago

  • Subject changed from Linkbrowser show not title auf Link to Inputlink field shows wrong explanation after update
  • Category set to FormEngine aka TCEforms

#11 Updated by Anonymous 13 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review 13 days ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62262

#13 Updated by Anonymous 13 days ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF