Bug #88774

Reinstitute "Composer mode" warning in Extension Manager

Added by Michael Schams 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2019-07-16
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If TYPO3 is installed from scratch using composer, the Extension Manager usually shows a warning that extensions can't be installed/removed via the web UI.

This still works in TYPO3 v9.5.8 (see attached screenshot0020.png), but does not work in TYPO3 v9.5.9-dev (see screenshot0021.png) and v10.0.0-dev anymore.

screenshot0020.png View - TYPO3 v9.5.8 (55.3 KB) Michael Schams, 2019-07-16 09:02

screenshot0021.png View - TYPO3 v9.5.9-dev (52.9 KB) Michael Schams, 2019-07-16 09:02

index.png View (45.8 KB) Susanne Moog, 2019-07-16 10:36

History

#1 Updated by Oliver Hader 5 months ago

Just guessing: Might be related to TYPO3_COMPOSER_MODE not being set anymore

#2 Updated by Susanne Moog 5 months ago

Hmm, how exactly did you install TYPO3? for me it's working fine with dev-master in composer mode (see screenshot, and ignore the font as I have loaded some custom styles)

#3 Updated by Susanne Moog 5 months ago

Ollys suggestion can be checked by looking at `vendor/typo3/autoload-include.php`; mine for example contains:

<?php
if (!getenv('TYPO3_PATH_COMPOSER_ROOT')) {
    putenv('TYPO3_PATH_COMPOSER_ROOT=' . dirname(dirname(__DIR__)));
    $_ENV['TYPO3_PATH_COMPOSER_ROOT'] = dirname(dirname(__DIR__));
}
if (!getenv('TYPO3_PATH_APP')) {
    putenv('TYPO3_PATH_APP=' . dirname(dirname(__DIR__)));
    $_ENV['TYPO3_PATH_APP'] = dirname(dirname(__DIR__));
}
if (!getenv('TYPO3_PATH_ROOT')) {
    putenv('TYPO3_PATH_ROOT=' . dirname(dirname(__DIR__)).'/public');
    $_ENV['TYPO3_PATH_ROOT'] = dirname(dirname(__DIR__)).'/public';
}
if (!getenv('TYPO3_PATH_WEB')) {
    putenv('TYPO3_PATH_WEB=' . dirname(dirname(__DIR__)).'/public');
    $_ENV['TYPO3_PATH_WEB'] = dirname(dirname(__DIR__)).'/public';
}
// TYPO3 is installed via composer. Flag this with a constant.
if (!defined('TYPO3_COMPOSER_MODE')) {
    define('TYPO3_COMPOSER_MODE', TRUE);
}

#4 Updated by Susanne Moog 5 months ago

  • Status changed from New to Rejected

Discussed with Michael in Slack, the problem is, that it is no composer installation but rather a core checkout where he did a composer install. So while TYPO3 dependencies were installed via composer, TYPO3 itself wasn't and usage of the extension manager in that setup is ok.

Also available in: Atom PDF