Project

General

Profile

Actions

Bug #88775

closed

logger in ApcuBackend is not instantiated

Added by Thomas Kieslich almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2019-07-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

$this->logger in Line 139 is never instantiated and i got this Error in Log:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: Call to a member function alert() on null | Error thrown in file /html/de.frosta.production/public/typo3/sysext/core/Classes/Cache/Backend/ApcuBackend.php in line 139


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #88938: wrong class statement for logger initializationClosedAnja Leichsenring2019-08-08

Actions
Is duplicate of TYPO3 Core - Bug #87820: Logger not instanciated in cache backendClosed2019-03-01

Actions
Actions #1

Updated by Daniel Windloff almost 5 years ago

The class \TYPO3\CMS\Core\Cache\Backend\AbstractBackend implements the LoggerAwareInterface and the LoggerAwareTrait.

But caching backend instances are created via "new" and not via GeneralUtility::makeInstance (see CacheManger:329).
So the logger is not set atm. This also affects the RedisBackend and the MemcachedBackend.

Actions #2

Updated by Georg Ringer over 4 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Daniel Windloff over 4 years ago

  • Is duplicate of Bug #87820: Logger not instanciated in cache backend added
Actions #4

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61472

Actions #5

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61472

Actions #6

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61472

Actions #7

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61472

Actions #8

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61460

Actions #9

Updated by Anja Leichsenring over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Anja Leichsenring over 4 years ago

  • Related to Bug #88938: wrong class statement for logger initialization added
Actions #11

Updated by Benni Mack over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF