Bug #88795

Firefox wants to save the rsa encrypted password instead of the plain text password

Added by Bernhard Eckl over 1 year ago. Updated 9 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2019-07-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am not sure if this is since the last Firefox update. I am using Firefox 68. When I login Firefox asks me to save the password. But it will not save the plain text passwort, it saves the rsa encrypted password (e.g. rsa:tTpOG0BCx7KoLIGGo+fMoqDm0WX479ahX40qCiJJzx19ftoQEGas77TP+JSSI5vUbs3i8ERoPzXNbiIlYtdyGc75NKqA+O3l9+yDSFNUBrFuPEDtm3VX6H/8tXBj8mBVNIaNd1Sq99byXBQvywvuIr/4PnsmQz3w2GX58JuTdxfWYr3NK7N755uapFL4jtf9kN5vtEjnuzJr3vvAaH2PlilWowbSF/P35iTI17KEtOX+9N9XvMBPZBfv7UZvR1iN0W68J8QxeSFpXAwb1Ew3mGnl7TmnkW+qUSEAY1u3SOyiHlW7Z7qzBwkKjZ4Byuz373mJCgyFEp6ASLJuNnwpXA==).

#1

Updated by Riccardo De Contardi over 1 year ago

I can confirm it on Firefox 68.0.1 on Mac; not reproducible on Chrome and Safari.

#2

Updated by Elias Villiger over 1 year ago

Can confirm that this has only been an issue since Firefox 68.
No issue with Firefox 67.0.4 on Windows, but is an issue with Firefox 68.0.1. Also using Typo3 8

#3

Updated by Elias Villiger over 1 year ago

See https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/9.1/Deprecation-81852-DeprecatedUsageOfEXTrsaauth.html
If you are on SSL you can (and should) safely deactivate rssauth to resolve this issue.

#4

Updated by Bernhard Eckl over 1 year ago

Okay, thanks.

#5

Updated by Georg Ringer 9 months ago

  • Status changed from New to Rejected

closed as rsaauth is not needed anymore

Also available in: Atom PDF