Bug #88874

TYPO3-CMS/lowlevel Missleading behavior and documentation

Added by Tobias Gaertner almost 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
CLI
Target version:
-
Start date:
2019-08-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Part from the docs:

Example script for checking your installation

#!/bin/sh
./typo3/sysext/core/bin/typo3 cleanup:orphanrecords -vv
./typo3/sysext/core/bin/typo3 cleanup:versions -vv
./typo3/sysext/core/bin/typo3 cleanup:multiplereferencedfiles -vv
./typo3/sysext/core/bin/typo3 cleanup:deletedrecords -v
./typo3/sysext/core/bin/typo3 cleanup:missingrelations -vv
./typo3/sysext/core/bin/typo3 cleanup:flexforms -vv
./typo3/sysext/core/bin/typo3 cleanup:missingfiles -vv
./typo3/sysext/core/bin/typo3 cleanup:lostfiles -vv

Example script for cleaning your installation

#!/bin/sh
./typo3/sysext/core/bin/typo3 cleanup:orphanrecords -vv
./typo3/sysext/core/bin/typo3 cleanup:versions -vv
./typo3/sysext/core/bin/typo3 cleanup:multiplereferencedfiles -vv  --update-refindex
./typo3/sysext/core/bin/typo3 cleanup:deletedrecords -v
./typo3/sysext/core/bin/typo3 cleanup:missingrelations -vv  --update-refindex
./typo3/sysext/core/bin/typo3 cleanup:flexforms -vv
./typo3/sysext/core/bin/typo3 cleanup:missingfiles --update-refindex
./typo3/sysext/core/bin/typo3 cleanup:lostfiles -vv  --update-refindex

These two are identical. And so is the script part under "Nightly reports of problems in the system".

  • Nightly reports of problems in the system
    - add the "--dry-run" parameter to all calls
    - do something with the output. e,g, pipe it into a log-file (otherwise the whole block is senseless)
  • Example script for checking your installation
    - add the "--dry-run" parameter to all calls
  • Example script for cleaning your installation
    - the command "./typo3/sysext/core/bin/typo3 cleanup:versions -vv" does no action.
    V8 we can add all the action paramter variants there - but honestly I find the behavior missleading, because the default is a dry-run. I changed my code locally to execute all actions by default.
    v9 the command is gone... should be removed from docs.

Related issues

Related to TYPO3 Core - Bug #79996: Update lowlevel's readmeClosedGeorg Ringer2017-02-24

Actions
#1

Updated by Jonas Eberle almost 2 years ago

Thank you for taking action on correcting this.
https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/lowlevel/README.rst

Could you propose how you would write it? If you want, push a patch to Gerrit (https://docs.typo3.org/m/typo3/guide-contributionworkflow/master/en-us/Index.html)

#2

Updated by Georg Ringer about 1 year ago

  • Related to Bug #79996: Update lowlevel's readme added
#3

Updated by Georg Ringer about 1 year ago

  • Status changed from New to Accepted
#4

Updated by Gerrit Code Review 12 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64530

#5

Updated by Gerrit Code Review 12 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64535

#6

Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64535

#7

Updated by Benni Mack 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF