Bug #88915

f:uri.action ignores pageUid

Added by Jonas Eberle about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2019-08-04
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

    always link to same page:
    <f:uri.action pageUid="84" action="show" />

    <f:link.action pageUid="84" action="show" >
        correct link
    </f:link.action>

Minimal test case: add a page with uid=2, then add this TypoScript on another page:

page = PAGE
page.10 = FLUIDTEMPLATE
page.10 {
  template = TEXT
  template.value (
    Uri:   <f:uri.action pageUid="2" extensionName="ext" pluginName="myPlugin" controller="controller" action="show" />
    <br>
    Link: <f:link.action pageUid="2" extensionName="ext" pluginName="myPlugin" controller="controller" action="show">link</f:link.action>
  )
}

The links should be the same. f:uri.action does not link to page 2, but to the current page.


Related issues

Related to TYPO3 Core - Task #87629: Harden \TYPO3\CMS\Extbase\Mvc\Web\Routing\UriBuilder Closed 2019-02-03

Associated revisions

Revision 7123269e (diff)
Added by Georg Ringer about 2 months ago

[BUGFIX] Correct variable usage in f:uri.action

Use the correct variables in f:uri.action which have been switched
with #87629.

Resolves: #88915
Releases: master
Change-Id: Icbdc3c7319bf2459a8eed2ca79961204e6d6153c
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61438
Tested-by: Alexander Schnitzler <>
Tested-by: TYPO3com <>
Tested-by: Josef Glatz <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Alexander Schnitzler <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Jonas Eberle about 2 months ago

9.5 is not affected, only master.

It seems to be introduced with this commit 85f739315388afd016cd301420fa48e62a59ff9c

I can't make any sense of it right now that 9.5 does not show the bug, though.

#2 Updated by Jonas Eberle about 2 months ago

  • Related to Task #87629: Harden \TYPO3\CMS\Extbase\Mvc\Web\Routing\UriBuilder added

#3 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61438

#4 Updated by Georg Ringer about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF