Bug #88923

Ticking a checkbox in a section will affect only the first element to be changed

Added by Marco Brummund 4 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-08-05
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

DCE version: 2.0.6
TYPO3 version: 9.5.8 LTS
PHP version: 7.2 =========================

When adding a checkbox to a section and trying to tick (check) it in the backend will only have effect to the very first element of the section array.

First of all I thought the checkbox was broken or had a wrong config (all elements but the fifth were collapsed, I tried to check the fifth box -> the checkbox did not show any reaction, but acting like "readonly")
After having a look to the configuration and not finding any error (by the way ... how should I? A checkbox only have 2 lines of config :D ) I expanded all section fields and recognized, that whatever I tick, only the first element will show effect.

I assume a missing dependency between checkbox and section Nth element.


Related issues

Related to TYPO3 Core - Bug #89092: Type "checkbox" within FlexForm sections Resolved 2019-09-05
Duplicated by Dynamic Content Elements (DCE) - Bug #89179: Checkbox in Section click-Event Rejected 2019-09-16

History

#1 Updated by Armin Vieweg 3 months ago

  • Project changed from Dynamic Content Elements (DCE) to TYPO3 Core
  • Target version deleted (2.1)

Hey. I've moved this issue to core project, because this is something which probably needs to get solved by the core itself.

I highly encourage to not use FlexForm sections anymore! Please check if the DCE container feature fits your requirements or check out Gridelements.

#2 Updated by Armin Vieweg 2 months ago

  • Duplicated by Bug #89179: Checkbox in Section click-Event added

#3 Updated by Georg Ringer about 1 month ago

  • Status changed from New to Closed

closing as duplicate of #89092

#4 Updated by Georg Ringer about 1 month ago

  • Related to Bug #89092: Type "checkbox" within FlexForm sections added

Also available in: Atom PDF