Bug #89064

Recycler deletes related data on restore

Added by Markus Klein about 2 years ago. Updated 17 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Recycler
Target version:
-
Start date:
2019-09-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

Situation

Table "Thing" with inline bookings.

Thing is translatable and deletable, bookings are neither.

Test case

  • Create sysfolder
  • Create Thing
  • Create Booking
  • Delete Thing
  • Restore Thing

Expected behavior

The booking is still there.

Seen behavior

The booking is gone by performing the last step.

Screen cast and demo extension are attached.

Only tested on v8, possibly present up to master.


Files

recdel.zip (13.7 KB) recdel.zip Demo extension Markus Klein, 2019-09-02 17:54
Recycler restore deletes data.mp4 (2.58 MB) Recycler restore deletes data.mp4 Screen cast Markus Klein, 2019-09-02 17:54
#1

Updated by Susanne Moog over 1 year ago

  • Status changed from New to Needs Feedback

When you delete "Thing" and have a dependent inline relation the datahandler will delete that relation on deletion of "Thing" - if that relation has no deleted field (is incapable of soft-delete) the relation will be hard deleted. The recycler obviously cannot restore it then. I don't quite get what the issue is. Maybe you can share more of your expectations and configuration?

#2

Updated by Markus Klein over 1 year ago

The point is that the recycler deletes records during the restore operation!

#3

Updated by Markus Klein over 1 year ago

  • Status changed from Needs Feedback to Accepted
#4

Updated by Georg Ringer 17 days ago

  • Status changed from Accepted to Needs Feedback

I just checked that in latest 11.5-dev-master and it works fine. can you double check? thanks

#5

Updated by Markus Klein 17 days ago

Confirmed, fixed in v11, still broken in latest v10

#6

Updated by Markus Klein 17 days ago

  • Status changed from Needs Feedback to Closed
  • Complexity set to hard

Wont't be fixed in older versions.

Also available in: Atom PDF