Bug #89125

Unnecessary DB queries to sys_language

Added by Benni Mack 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
Backend API
Start date:
2019-09-10
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since site handling, finding the correct languages and the amount of languages in a page can be simplified.


Related issues

Related to TYPO3 Core - Task #69144: Unify language-dropdown-creation Closed 2015-08-18

Associated revisions

Revision f329f0ce (diff)
Added by Benni Mack 3 months ago

[BUGFIX] Avoid unnecessary DB queries to sys_language

Since site handling, finding the correct languages and the amount of languages in a page can be simplified.

NewRecordController->checkIfLanguagesExist() is never in use, and can be removed completely.

Resolves: #89125
Releases: master
Change-Id: I523bf8ecdf0598d7acb062200710c4fae2935cc5
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61656
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Susanne Moog <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61656

#2 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61656

#3 Updated by Benni Mack 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Georg Ringer about 2 months ago

  • Related to Task #69144: Unify language-dropdown-creation added

Also available in: Atom PDF