Bug #89140

Page module: Translation wizard should respect available languages via configured Site

Added by Benni Mack 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
Link Handling, Site Handling & Routing
Start date:
2019-09-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #89442: [BREAKING] Error "Column 'sys_language_uid' in where clause is ambiguous" when trying to translate CEs as non-admin user Resolved 2019-10-17

Associated revisions

Revision b46e1d09 (diff)
Added by Benni Mack 2 months ago

[BUGFIX] Select available languages based on Site configuration

When the translation wizard in the Page Module
fetches translations and possible languages, it
queries the sys_language records - however since SiteMatcher/SiteFinder
already does this on a per-page level (currently via TranslationConfigurationProvider)
the LocalizationRepository can find allowed language IDs
directly instead of querying the sys_language table, which might
contain 20 languages, but only 2 are available for this pagetree.

Resolves: #89140
Releases: master, 9.5
Change-Id: I8e755e4cc3bdbae7dc4dd71319b8ffc8120200a4
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61664
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Susanne Moog <>

Revision f66df41c (diff)
Added by Benni Mack 2 months ago

[BUGFIX] Select available languages based on Site configuration

When the translation wizard in the Page Module
fetches translations and possible languages, it
queries the sys_language records - however since SiteMatcher/SiteFinder
already does this on a per-page level (currently via TranslationConfigurationProvider)
the LocalizationRepository can find allowed language IDs
directly instead of querying the sys_language table, which might
contain 20 languages, but only 2 are available for this pagetree.

Resolves: #89140
Releases: master, 9.5
Change-Id: I8e755e4cc3bdbae7dc4dd71319b8ffc8120200a4
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61672
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

Revision a09d55ca (diff)
Added by Daniel Goerz about 1 month ago

[BUGFIX] Use alias for constraining languages while translating

This patch fixes a regression that led to an uncaught exception
during the translation of content elements for non admin backend
users by respecting the table alias declared in the JOIN when
adding constraints for allowed languages.

Resolves: #89442
Related: #89140
Releases: master, 9.5
Change-Id: Ib6539827494cdeffe9326d0cdfaec7cebff28224
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62013
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Markus Klein <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Frank Nägler <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Frank Nägler <>

Revision aa20c0f2 (diff)
Added by Daniel Goerz about 1 month ago

[BUGFIX] Use alias for constraining languages while translating

This patch fixes a regression that led to an uncaught exception
during the translation of content elements for non admin backend
users by respecting the table alias declared in the JOIN when
adding constraints for allowed languages.

Resolves: #89442
Related: #89140
Releases: master, 9.5
Change-Id: Ib6539827494cdeffe9326d0cdfaec7cebff28224
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61983
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Reviewed-by: Frank Nägler <>

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61664

#2 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61664

#3 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61664

#4 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61672

#5 Updated by Benni Mack 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Daniel Goerz about 1 month ago

  • Related to Bug #89442: [BREAKING] Error "Column 'sys_language_uid' in where clause is ambiguous" when trying to translate CEs as non-admin user added

Also available in: Atom PDF