Bug #89155

AdminPanel Log module broken after PSR-3 changes

Added by Susanne Moog about 1 month ago. Updated 28 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-09-12
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since https://review.typo3.org/c/Packages/TYPO3.CMS/+/61156 the admin panel log module is broken as the wrong levels/strings are used for level comparison.


Related issues

Related to TYPO3 Core - Feature #88799: Use PSR-3 interface for logging Closed 2019-07-19

Associated revisions

Revision 1face766 (diff)
Added by Susanne Moog 28 days ago

[BUGFIX] Use correct log level integer / strings in admin panel

Since #88799 the wrong log levels were used for configuration and
level comparison (strings where ints were required, ints where strings
should have been). The patch streamlines the use of the log levels to
re-introduce a working log module.

Resolves: #89155
Releases: master
Change-Id: I1faf2b8df77fd6e412eea7cb63180026e6c19969
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61693
Tested-by: Benjamin Franzke <>
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Benjamin Franzke <>
Reviewed-by: Markus Klein <>
Reviewed-by: Jörg Bösche <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61693

#2 Updated by Markus Klein about 1 month ago

#3 Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61693

#4 Updated by Susanne Moog 28 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF