Bug #89275

IRRE fields marked as error, even when they are not required

Added by Dennis Römmich about 2 years ago. Updated over 1 year ago.

Status:
Accepted
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-09-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a display issue with a special TCA definition.
Given is a basic image field.
The only special configuration is:

    'columnsOverrides' => [
        'assets' => [
            'config' => [
                'minitems' => 2,
                'maxitems' => 2,
            ],
        ],
  ],

After uploading the first image, all metadata fields in the first image are marked as required. After uploading the second image, the fields aren't marked as required anymore. The reason is the css property:

.has-error .form-control {
    border-color: #c83c3c;
    box-shadow: inset 0 1px 1px rgba(0,0,0,.075);
}

Expected behavior:
Imagefield should marked as an error because minitems is set to 2.
Metadata fields shouldn't marked as required after uploading only the first image.


Files


Related issues

Is duplicate of TYPO3 Core - Bug #82481: TCA type "inline" with min items marks all fields as requiredAccepted2017-09-14

Actions
#1

Updated by Georg Ringer about 2 years ago

  • Subject changed from Image Metadata fields marked as error, even when they are not required to IRRE fields marked as error, even when they are not required
  • Status changed from New to Accepted
#2

Updated by Georg Ringer over 1 year ago

closed as duplicate of #82481

#3

Updated by Georg Ringer over 1 year ago

  • Is duplicate of Bug #82481: TCA type "inline" with min items marks all fields as required added

Also available in: Atom PDF