Bug #89314

Flaws in distributed site configurations

Added by Oliver Hader about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Start date:
2019-09-30
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Site-related configuration in distribution packages has a couple of flaws:

  • existing site configurations for the same identifier are overridden on file system level
  • installations that already have a page or page tree still import site configuration with hard-coded root-page "1" which does not work

This has been introduced to TYPO3 v10.1 in #89010


Related issues

Related to TYPO3 Core - Feature #89010: API for site configuration shipped with distribution Resolved 2019-08-25

Associated revisions

Revision 9ec1d3b0 (diff)
Added by Oliver Hader about 2 months ago

[BUGFIX] Streamline site configuration import in distribution packages

Site configuration shipped in distribution packages had a couple of flaws
during import process which are tackled with this change:

  • existing site configurations for same identifier are not overridden on
    the file system level anymore (according warning is logged)
  • site configuration is now updated and mapped to for imported pages,
    which did not work before due to hard-coded rootPageId in config.yaml
    (warning is logged in case root page id cannot be mapped)

Resolves: #89314
Releases: master
Change-Id: I856024afb50186eb9f6cc73ef13f1961c948c784
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61864
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Oliver Hader <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Oliver Hader <>

History

#1 Updated by Oliver Hader about 2 months ago

  • Description updated (diff)

#2 Updated by Oliver Hader about 2 months ago

  • Related to Feature #89010: API for site configuration shipped with distribution added

#3 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61864

#4 Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61864

#5 Updated by Gerrit Code Review about 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61864

#6 Updated by Gerrit Code Review about 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61864

#7 Updated by Oliver Hader about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF