Bug #89387

Tasks backend:lock & backend:unlock most not be schdulable

Added by Georg Ringer 6 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-10-10
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The tasks backend:lock and backend:unlock must not be allowed to be triggered via backend. this doesn't make any sense.

triggered it by accident (As it is the 1st task) and locked myself and full backend and of course couldn't get back via backend.


Related issues

Related to TYPO3 Core - Bug #89873: backend:lock/backend:unlock are not longer available as scheduler tasks Closed 2019-12-06

Associated revisions

Revision 26c9a8e3 (diff)
Added by Georg Ringer 6 months ago

[BUGFIX] Set tasks backend:lock & backend:unlock as not schedulable

The tasks `backend:lock` and `backend:unlock` must only be triggered
by commandline and not via backend as this doesn't make any sense.
Any admin would disable his own account by locking via backend and there
is no chance to unlock it again.

Resolves: #89387
Releases: master, 9.5
Change-Id: Ief460cfc033b555e77869b22b61b05c57a27d1a7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61938
Tested-by: Christian Eßl <>
Tested-by: Jörg Bösche <>
Tested-by: TYPO3com <>
Tested-by: Sascha Rademacher <>
Tested-by: Henning Liebe <>
Tested-by: Richard Haeser <>
Reviewed-by: Christian Eßl <>
Reviewed-by: Jörg Bösche <>
Reviewed-by: Sascha Rademacher <>
Reviewed-by: Henning Liebe <>
Reviewed-by: Richard Haeser <>

Revision aea66552 (diff)
Added by Georg Ringer 6 months ago

[BUGFIX] Set tasks backend:lock & backend:unlock as not schedulable

The tasks `backend:lock` and `backend:unlock` must only be triggered
by commandline and not via backend as this doesn't make any sense.
Any admin would disable his own account by locking via backend and there
is no chance to unlock it again.

Resolves: #89387
Releases: master, 9.5
Change-Id: Ief460cfc033b555e77869b22b61b05c57a27d1a7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61925
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>
Reviewed-by: Richard Haeser <>

History

#1 Updated by Gerrit Code Review 6 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61938

#2 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61925

#3 Updated by Georg Ringer 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benjamin Franzke 4 months ago

  • Related to Bug #89873: backend:lock/backend:unlock are not longer available as scheduler tasks added

#5 Updated by Benjamin Franzke 4 months ago

  • Status changed from Resolved to Accepted

The schedulers primary task is to schedule tasks, not to execute them from the backend.
The backend-execution is an additional functionality, because it's sometime handy for manual tasks/testing.

This patch regresses and actually drops perfectly valid scheduler functionality:
  • Planned Maintenance locks:
    schedule a backend lock for a planned update or migration where you agreed to stop editing as of a certain date.
  • Regular edit-locks, e.g.:
    schedule a backend lock for let's say every friday as of 8pm
    schedule backend unlock on mondays at 8am.

Therefore let's revert this patch. Patch is here:
https://review.typo3.org/c/Packages/TYPO3.CMS/+/62551

#6 Updated by Georg Ringer about 1 month ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF