Bug #89873

backend:lock/backend:unlock are not longer available as scheduler tasks

Added by Benjamin Franzke about 1 month ago. Updated 25 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
scheduler
Start date:
2019-12-06
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

#89387 dropped the support with the patch in https://review.typo3.org/c/Packages/TYPO3.CMS/+/61938
The reason was to fix execution from the backend.

The schedulers primary task is to schedule tasks, not to execute them from the backend.
The backend-execution is only an additional functionality, which is available because it's sometime handy for manual tasks/testing.
We shouldn't mark commands as non-schedulable when scheduling them is a perectly valid usecase.


Related issues

Related to TYPO3 Core - Bug #89387: Tasks backend:lock & backend:unlock most not be schdulable Accepted 2019-10-10

Associated revisions

Revision 048935e3 (diff)
Added by Benjamin Franzke about 1 month ago

Revert "[BUGFIX] Set tasks backend:lock & backend:unlock as not schedulable"

This reverts commit 26c9a8e32637d506249989318941c923171b7658.

The schedulers primary task is to schedule tasks, not to execute them
from the backend. The backend-execution is only an additional
functionality, which is available because it's sometime handy for manual
tasks/testing.

We shouldn't mark commands as non-schedulable when scheduling them is a
perectly valid usecase.
Usecases for scheduling backend locks are:
  • Planned maintenance locks:
    schedule a backend lock for a planned update or migration where you
    agreed to stop editing as of a certain date.
  • Regular edit-locks, e.g.:
    schedule a backend lock for let's say every friday as of 8pm
    schedule backend unlock on mondays at 8am.

The reverted patch tried to fix the situation where the lock task was
executed from the backend scheduler overview. If we'd want to fix that,
the proper fix would be to add another property which states that this
command must not be executed from the backend.

Releases: master, 9.5
Resolves: #89873
Reverts: #89387
Change-Id: I782809ff065c05adba0653aa208d37e1241eb41a
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62551
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Tested-by: Markus Klein <>
Tested-by: Benjamin Franzke <>
Reviewed-by: Frank Nägler <>
Reviewed-by: Markus Klein <>
Reviewed-by: Benjamin Franzke <>

Revision 22f5d2c9 (diff)
Added by Benjamin Franzke about 1 month ago

Revert "[BUGFIX] Set tasks backend:lock & backend:unlock as not schedulable"

This reverts commit 26c9a8e32637d506249989318941c923171b7658.

The schedulers primary task is to schedule tasks, not to execute them
from the backend. The backend-execution is only an additional
functionality, which is available because it's sometime handy for manual
tasks/testing.

We shouldn't mark commands as non-schedulable when scheduling them is a
perectly valid usecase.
Usecases for scheduling backend locks are:
  • Planned maintenance locks:
    schedule a backend lock for a planned update or migration where you
    agreed to stop editing as of a certain date.
  • Regular edit-locks, e.g.:
    schedule a backend lock for let's say every friday as of 8pm
    schedule backend unlock on mondays at 8am.

The reverted patch tried to fix the situation where the lock task was
executed from the backend scheduler overview. If we'd want to fix that,
the proper fix would be to add another property which states that this
command must not be executed from the backend.

Releases: master, 9.5
Resolves: #89873
Reverts: #89387
Change-Id: I782809ff065c05adba0653aa208d37e1241eb41a
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62463
Tested-by: TYPO3com <>
Tested-by: Benjamin Franzke <>
Reviewed-by: Benjamin Franzke <>

History

#1 Updated by Benjamin Franzke about 1 month ago

  • Related to Bug #89387: Tasks backend:lock & backend:unlock most not be schdulable added

#2 Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62551

#3 Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62551

#4 Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62463

#5 Updated by Benjamin Franzke about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 25 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF