Bug #89588

IRRE: Original unique value not properly created

Added by Andreas Fernandez 16 days ago. Updated 12 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2019-11-05
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The array containing the unique value identification is passed as-is into GeneralUtility::implodeAttributes(), which does an implicit htmlspecialchars() and fails with an error message.

How to reproduce

Have EXT:styleguide installed, open the page "inline mngroup" and try to edit the record inline mn group "lipsum".


Related issues

Related to TYPO3 Core - Bug #87711: Site Management site not working when you delete only available language Resolved 2019-02-14

Associated revisions

Revision 9b426a5a (diff)
Added by Andreas Fernandez 12 days ago

[BUGFIX] IRRE: Create a correct original value identifier

The value of `data-table-unique-original-value` was accidentally of type
array. This causes runtime errors since a string is expected.

This patch now creates a proper value passed to FormEngine to handle the
original unique value.

Resolves: #89588
Related: #87711
Releases: master, 9.5
Change-Id: I9184aa025f01196d0c206b5b86c712dc1049487f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62195
Tested-by: Oliver Bartsch <>
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Susanne Moog <>

Revision 0037e82b (diff)
Added by Andreas Fernandez 12 days ago

[BUGFIX] IRRE: Create a correct original value identifier

The value of `data-table-unique-original-value` was accidentally of type
array. This causes runtime errors since a string is expected.

This patch now creates a proper value passed to FormEngine to handle the
original unique value.

Resolves: #89588
Related: #87711
Releases: master, 9.5
Change-Id: I9184aa025f01196d0c206b5b86c712dc1049487f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62264
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Andreas Fernandez 16 days ago

  • Category set to FormEngine aka TCEforms
  • Is Regression set to Yes

#2 Updated by Andreas Fernandez 16 days ago

  • Related to Bug #87711: Site Management site not working when you delete only available language added

#3 Updated by Gerrit Code Review 16 days ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62195

#4 Updated by Gerrit Code Review 16 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62195

#5 Updated by Gerrit Code Review 12 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62195

#6 Updated by Gerrit Code Review 12 days ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62264

#7 Updated by Andreas Fernandez 12 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF