Bug #87711

Site Management site not working when you delete only available language

Added by Pascal Querner 9 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Could have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-02-14
Due date:
% Done:

100%

Estimated time:
1.00 h
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

Hey,

I know this sounds weird and should never be really an issue. But when having a single language TYPO3 instance with a working site configuration and you delete the only language configuration from that it won't let you save the site configuration because "Available languages for this site" is empty and cannot be (re)added.
If you remove that language configuration it should be readded back to the list.

The only workaround for this is to completely delete the site configuration and start over.

Tested only on TYPO3 9.5.4 running nginx with PHP 7.3.

Screenshot 2019-02-14 at 09.52.09.png View (30.4 KB) Pascal Querner, 2019-02-14 09:52


Related issues

Related to TYPO3 Core - Bug #89588: IRRE: Original unique value not properly created Resolved 2019-11-05

Associated revisions

Revision 3fa7f9ef (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Fix IRRE uniqueness flaws

This patch fixes some flaws in the IRRE uniqueness handling:

- Validation is triggered once a record has been removed from DOM
- Removed records are now added to their selector again if not opened
before
- Uniqueness handling now works for records with uid "0", which is
relevant for a site's language handling
- The unique update is now triggered only when the value of its selector
in a record actually changes

Resolves: #87711
Releases: master, 9.5
Change-Id: I9fe15d8e8790eff305024b706450cd2c37da9340
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578
Reviewed-by: Susanne Moog <>
Reviewed-by: Frank Nägler <>
Tested-by: Susanne Moog <>
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>

Revision 9ede1b30 (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Fix IRRE uniqueness flaws

This patch fixes some flaws in the IRRE uniqueness handling:

- Removed records are now added to their selector again if not opened
before
- Uniqueness handling now works for records with uid "0", which is
relevant for a site's language handling
- Changing a field marked for uniqueness handling now updates the value
selector properly

Resolves: #87711
Releases: master, 9.5
Change-Id: I9fe15d8e8790eff305024b706450cd2c37da9340
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Tested-by: Frank Nägler <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Frank Nägler <>

Revision 9b426a5a (diff)
Added by Andreas Fernandez 3 days ago

[BUGFIX] IRRE: Create a correct original value identifier

The value of `data-table-unique-original-value` was accidentally of type
array. This causes runtime errors since a string is expected.

This patch now creates a proper value passed to FormEngine to handle the
original unique value.

Resolves: #89588
Related: #87711
Releases: master, 9.5
Change-Id: I9184aa025f01196d0c206b5b86c712dc1049487f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62195
Tested-by: Oliver Bartsch <>
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Susanne Moog <>

Revision 0037e82b (diff)
Added by Andreas Fernandez 3 days ago

[BUGFIX] IRRE: Create a correct original value identifier

The value of `data-table-unique-original-value` was accidentally of type
array. This causes runtime errors since a string is expected.

This patch now creates a proper value passed to FormEngine to handle the
original unique value.

Resolves: #89588
Related: #87711
Releases: master, 9.5
Change-Id: I9184aa025f01196d0c206b5b86c712dc1049487f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62264
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Susanne Moog 8 months ago

  • Category changed from System/Bootstrap/Configuration to Link Handling, Site Handling & Routing

#2 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#3 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#4 Updated by Gerrit Code Review 2 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#5 Updated by Gerrit Code Review 2 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#6 Updated by Gerrit Code Review 2 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#7 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#8 Updated by Gerrit Code Review 2 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#9 Updated by Gerrit Code Review 2 months ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#10 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#11 Updated by Gerrit Code Review 2 months ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#12 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#13 Updated by Gerrit Code Review 2 months ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#14 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#15 Updated by Gerrit Code Review 2 months ago

Patch set 5 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#16 Updated by Gerrit Code Review 2 months ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61578

#17 Updated by Gerrit Code Review 2 months ago

Patch set 6 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61626

#18 Updated by Andreas Fernandez 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Andreas Fernandez 7 days ago

  • Related to Bug #89588: IRRE: Original unique value not properly created added

Also available in: Atom PDF