Bug #89638

BackendUserConfigurationUpdate Upgrade Wizard fails on empty UC fields

Added by Daniel Goerz over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
-
Start date:
2019-11-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The newly introduced Upgrade Wizard for legacy UC field contents fails with an exception if any be_user has an empty (null) uc field.

Reproduce:
  1. Have a BE user with a stdClass in the serialized array of the uc field so that the upgrade wizard does its thing.
  2. Set the uc field of any active be_user to null
  3. Run the Upgrade Wizard "BackendUserConfigurationUpdate"

Related issues

Related to TYPO3 Core - Bug #89269: $GLOBALS['BE_USER']->uc sometimes wrongly written, gets a stdClass where an array would be expectedClosed2019-09-25

Actions
Related to TYPO3 Core - Bug #89268: Cannot use object of type stdClass as array in BackendUserConfiguration.phpClosedChristian Eßl2019-09-25

Actions
Related to TYPO3 Core - Bug #86398: Interface state can't be savedClosed2018-09-27

Actions
Related to TYPO3 Core - Bug #89683: Install Tool - Update backend user configuration array fails due to wrong variable type in $backendUser['uid']Closed2019-11-14

Actions
#1

Updated by Daniel Goerz over 1 year ago

  • Related to Bug #89269: $GLOBALS['BE_USER']->uc sometimes wrongly written, gets a stdClass where an array would be expected added
#2

Updated by Daniel Goerz over 1 year ago

  • Related to Bug #89268: Cannot use object of type stdClass as array in BackendUserConfiguration.php added
#3

Updated by Daniel Goerz over 1 year ago

  • Related to Bug #86398: Interface state can't be saved added
#4

Updated by Robert Böttner over 1 year ago

  • Related to Bug #89683: Install Tool - Update backend user configuration array fails due to wrong variable type in $backendUser['uid'] added
#5

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62368

#6

Updated by Daniel Goerz over 1 year ago

  • Description updated (diff)
#7

Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62393

#8

Updated by Daniel Goerz over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF