Bug #89758

File Metadata cannot be translated anymore

Added by Susanne Moog about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-05-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since https://review.typo3.org/c/Packages/TYPO3.CMS/+/60843 file metadata cannot be translated in the file module as we are now fetching languages from the site object (which is a NullSite in this case and therefor only contains default language).

In this case, it's necessary to fetch all available languages of an installation to make translating file metadata to all languages possible again.

Possible solutions:
- Query sys_language (as before)
- Aggregate all language configurations from all available sites (allows to get rid of the sys_language dependency at a later point)


Related issues

Is duplicate of TYPO3 Core - Bug #88897: sys_file_metadata can't be translatedClosed2019-08-02

Actions
Follows TYPO3 Core - Task #88461: Remove leftover code from PseudoSite HandlingClosedBenni Mack2019-05-29

Actions
#1

Updated by Susanne Moog about 1 year ago

  • Due date set to 2019-05-30
  • Start date changed from 2019-11-23 to 2019-05-30
  • Follows Task #88461: Remove leftover code from PseudoSite Handling added
#2

Updated by Susanne Moog about 1 year ago

  • Due date deleted (2019-05-30)
  • Is Regression set to Yes
#3

Updated by Daniel Goerz 11 months ago

  • Is duplicate of Bug #88897: sys_file_metadata can't be translated added
#4

Updated by Daniel Goerz 11 months ago

  • Status changed from New to Closed

Resolved with #88897

Also available in: Atom PDF