Bug #90084

Event Dispatcher missing in Maintenance -> Remove temporary assets

Added by Anja Leichsenring about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2020-01-10
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

An exception is thrown upon Maintenance -> Remove temporary assets action from install tool and in BE context:

(1/1) ArgumentCountError
Too few arguments to function TYPO3\CMS\Core\Resource\ResourceFactory::__construct(), 0 passed in /var/www/html/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 3463 and exactly 1 expected


Related issues

Related to TYPO3 Core - Feature #89577: Replace FAL signals with new PSR-14 events Closed 2019-11-04
Duplicates TYPO3 Core - Bug #89891: Temporary assets can not be removed in install tool, exception occurs Under Review 2019-12-06

History

#1 Updated by Anja Leichsenring about 1 month ago

  • Related to Feature #89577: Replace FAL signals with new PSR-14 events added

#2 Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62842

#3 Updated by Anja Leichsenring about 1 month ago

  • Description updated (diff)

#4 Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62842

#5 Updated by Daniel Goerz about 1 month ago

  • Duplicates Bug #89891: Temporary assets can not be removed in install tool, exception occurs added

#6 Updated by Daniel Goerz about 1 month ago

  • Status changed from Under Review to Closed

Closed as dupe of #89891

Also available in: Atom PDF