Feature #90138

Language and mode (free or connected) should be handled in the links module when creating an anchor to content

Added by Rachel Foucard over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-01-16
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
translation, localization
Complexity:
Sprint Focus:

Description

Hello,

In a page translated with the free mode (so the translated contents are not related to original contents), when I'm in the translated language, I want to create a link to a translated content via the link module, but I only get the original content list in a page.

I think that it should list the translated contents only when the page is in free mode, but the original contents when the page is in connected mode.

Here is a workaround for those who have the same problem :

I used the linkHandler functionality with
this tsconfig:

TCEMAIN.linkHandler.anchors {
    handler = TYPO3\CMS\Recordlist\LinkHandler\RecordLinkHandler
    label = Anchors
    configuration {
        table = tt_content
    }
    scanBefore = page
}

and this typoscript :
config.recordLinks.anchors {
    // Do not force link generation when the record is hidden
    forceLink = 0
    typolink {
        parameter = current
        parameter.dataWrap = |#{field:uid}
    }
}

It does the job for the moment without coding anything, but I would prefer that the native tab listing contents handle the languages context.

Cheers,
Rachel


Related issues

Related to TYPO3 Core - Bug #89701: Link wizard lists only content elements of the default languageClosed2019-11-18

Actions
Related to TYPO3 Core - Bug #88690: Translated content elements are not available in linkbrowser of the ckeditor in free modeNew2019-07-05

Actions
#1

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #89701: Link wizard lists only content elements of the default language added
#2

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #88690: Translated content elements are not available in linkbrowser of the ckeditor in free mode added
#3

Updated by Riccardo De Contardi over 1 year ago

Can this be considered the same issue? #89701

#4

Updated by Rachel Foucard over 1 year ago

Yes Riccardo, #89701 and #88690 are exactly the same issue. Sorry, didn't check that!
Rakel

#5

Updated by Riccardo De Contardi over 1 year ago

Rachel Tjong-A-Hung Foucard do not worry and thank you for your feedback!

I close this issue as a duplicate of #89701 please continue the discussion there. If you think that this is the wrong decision, please reopen it or ping me.

Thank you

#6

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF