Project

General

Profile

Actions

Bug #90302

closed

DatabaseTreeDataProvider crashes after switching to PSR-14

Added by Georg Ringer over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2020-02-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After #89733 the feature of custom tree providers doesn't work anymore.

Reason is that in TreeDataProviderFactory line 44 there is this call

$dataProvider = GeneralUtility::makeInstance($tcaConfiguration['treeConfig']['dataProvider'], $tcaConfiguration, $table, $field, $currentValue);

this will call the treeprovider with the tcaConfiguration as 1st constructor parameter which of course won't work anymore because this is no using DI

    public function __construct(EventDispatcherInterface $eventDispatcher)
    {
        $this->eventDispatcher = $eventDispatcher;
    }


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #89733: Migrate various Signal Slots to PSR-14 eventsClosedBenni Mack2019-11-21

Actions
Related to TYPO3 Core - Bug #90399: Unable to use EventDispatcherInterface in custom TreeDataProviderClosed2020-02-16

Actions
Actions #1

Updated by Georg Ringer over 4 years ago

  • Related to Feature #89733: Migrate various Signal Slots to PSR-14 events added
Actions #2

Updated by Christoph Lehmann over 4 years ago

  • Related to Bug #90399: Unable to use EventDispatcherInterface in custom TreeDataProvider added
Actions #3

Updated by Georg Ringer over 4 years ago

  • Target version set to 10 LTS
Actions #4

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63184

Actions #5

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63184

Actions #6

Updated by Benni Mack over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF