Feature #90396

PageTitle API: possibility to remove site title from SEO title

Added by Sebastian Klein over 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
SEO
Target version:
-
Start date:
2020-02-16
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
SEO, PageTitle API, Frontend
Complexity:
Sprint Focus:

Description

Goal:

When I set an individual SEO title for a page, I want to be able to remove the default site title (which was set in Site Configuration).

Example:

Say, your page would by default have a title like "Current page title: ACME Incorporated".
"ACME Incorporated" is loaded from the new website title configuration in the Sites module (Feature #85592). The colon is the default pageTitleSeparator.

For an optimised page, I now want the SEO title "Get this awesome product from ACME". The website title and pageTitleSeparator should not be appended here at all.

Until now I got the desired result with some TypoScript:

// For pages:
config {
    pageTitle.noTrimWrap = ## | ACME Incorporated#
    pageTitle.noTrimWrap.splitChar = #
    pageTitle.noTrimWrap.if.isFalse.data = page:seo_title
}

// and for EXT:news:
[request.getQueryParams() ['tx_news_pi1'] > 0]
    config.pageTitle.noTrimWrap.if.isFalse {
        data >
        dataWrap = DB:tx_news_domain_model_news:{GP:tx_news_pi1|news}:alternative_title
        wrap3 = {|}
        insertData = 1
    }
[end]

In TYPO3 v10, this TypoScript would continue to work, as long as I don't use the new website title configuration.

It would be nice to configure this with TypoScript or some other way.


Related issues

Is duplicate of TYPO3 Core - Feature #88771: Page Title TemplatesUnder ReviewRichard Haeser2019-07-15

Actions
#1

Updated by Richard Haeser 8 months ago

  • Status changed from New to Closed

This is one of the reasons I started #88771. Will work on this in the near future. I will close this issue and will continue to work on #88771.

#2

Updated by Richard Haeser 8 months ago

Also available in: Atom PDF