Task #90415

Clarify change "Important: #86785 - Calling scheduler command on CLI throws error if not in /var/www/html" ?

Added by Sybille Peters 8 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Documentation
Target version:
-
Start date:
2020-02-18
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

changelog: Important: #86785 - Calling scheduler command on CLI throws error if not in /var/www/html

I am trying to understand what the change is about. It seems weird that the title of the change is the same as the title of the issue - does it describe the problem or the solution?

I am assuming the problem is that an error is thrown and the solution is something else (not throw an error, read correct path of web root, ...?).

If my assumption is correct, I would suggest to update the description (and possibly the title though that is a little ugly because it results in filename / title mismatch).

Also, there is no migration path. According to the change, there is nothing that needs to be done, but there is a comment in the review which suggests otherwise: https://review.typo3.org/c/Packages/TYPO3.CMS/+/59237/


Related issues

Related to TYPO3 Core - Bug #86785: Calling scheduler command on CLI throws error if not in /var/www/html Closed 2018-12-21

Associated revisions

Revision 63ad62f3 (diff)
Added by Susanne Moog 8 months ago

[DOCS] Clarify changed logger instantiation in scheduler tasks

Resolves: #90415
Releases: master, 9.5
Change-Id: Icb403e6ef2892ff7988a34652d6cdfa8f8bd1cfd
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63601
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Oliver Bartsch <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Benni Mack <>

Revision 906a09e5 (diff)
Added by Susanne Moog 8 months ago

[DOCS] Clarify changed logger instantiation in scheduler tasks

Resolves: #90415
Releases: master, 9.5
Change-Id: Icb403e6ef2892ff7988a34652d6cdfa8f8bd1cfd
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63580
Tested-by: Georg Ringer <>
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Susanne Moog 8 months ago

  • Status changed from New to Needs Feedback

To explain:

The problem happened when you created a scheduler task in one environment (for example one where TYPO3 was running in /var/www/html) - and then you take that database and move to another environment (where TYPO3 is running somewhere else, for example in /var/www/something). Now trying to execute any task in the scheduler results in an error, because the Logger that was stored with the task in the database has the wrong log file path.

To get rid of that problem, the logger is no longer stored with the task in the database, but instead re-instantiated when the task is run (which means it checks for correct paths on the current environment).

Hope that makes it clearer - ideally, you could adjust the rst file so it's more understandable for the general public.

As to the comment from Markus: That's not directly about what the fix does, but rather about a change in behaviour that was introduced. As that was quite some time ago, I'd probably leave it like it is currently.

#2 Updated by Susanne Moog 8 months ago

  • Related to Bug #86785: Calling scheduler command on CLI throws error if not in /var/www/html added

#3 Updated by Gerrit Code Review 8 months ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63601

#4 Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63580

#5 Updated by Susanne Moog 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF