Project

General

Profile

Actions

Bug #90479

closed

New fluidbased PageLayoutView throws error, if backendLayout can no longer be resolved

Added by Christian Eßl about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2020-02-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce:
- Install introduction package on master (which then automatically imports a pagetree)
- deinstall the introduction package in the extension manager
- Go to the page module and open a page.

The new fluidbased page module will now throw an error:

Call to a member function getDrawingConfiguration() on null

in line:

$backendLayout = $this->backendLayouts->getDataProviderCollection()->getBackendLayout(
                $selectedCombinedIdentifier,
                $this->id
            );

$configuration = $backendLayout->getDrawingConfiguration();

which happens in DataProviderCollection::getBackendLayout();

Because the configured backend layout of the previously installed extension is now missing. If a backendLayout cannot be resolved, there should be either:
  • thrown an exception, that the backendLayout can't be resolved
  • or a fallback to the "default" backend layout.

I think the latter option was the behaviour in the old PageLayoutView.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #90348: PageLayoutView and BackendLayout should be refactored to separate rendering, processing and fetching of contentClosed2020-02-10

Actions
Actions #1

Updated by Christian Eßl about 4 years ago

  • Related to Task #90348: PageLayoutView and BackendLayout should be refactored to separate rendering, processing and fetching of content added
Actions #2

Updated by Christian Eßl about 4 years ago

  • Description updated (diff)
Actions #3

Updated by Christian Eßl about 4 years ago

  • Description updated (diff)
Actions #4

Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63370

Actions #5

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63370

Actions #6

Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63388

Actions #7

Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63370

Actions #8

Updated by Christian Eßl almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF