Bug #90541

page can't be translated if pages:l10n_parent is not set for an editor

Added by Dave Zen over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
Start date:
2020-02-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
l10n
Complexity:
Is Regression:
Sprint Focus:

Description

An editor wanted to translate a page but he got an error that "tableName" is null. Afterwards, the translated page was not created.

After some testing I found out that

Ursprungstext (l10n_parent) [pages:l10n_parent]
was not set. If the editor has the right for this field, the translation worked.
The error message in the picture appeared with L10nMgr installed and activated.

If I deactivate L10nMgr the editor gets only a spinning circle and nothing happens, after he had chosen to translate the page. (So the issue does not seem to be related only to the l10nmgr extension.)
If the editor cancels the process after 20sec and goes back via the browser back button the translated page wasn't created.

When an admin then tries to translate the page he then will get a message, that the translated page already exists (which is wrong, because the translated page does not exist) and therefore it's now impossible to create a translation.

TYPO3 9.5.14


Files

missingTable2.JPG (26.2 KB) missingTable2.JPG error message that page already exists Dave Zen, 2020-02-26 12:44
missingTable_edit.jpg (190 KB) missingTable_edit.jpg error message when editor tries to create a page Dave Zen, 2020-02-26 12:44

Related issues

Related to TYPO3 Core - Bug #89672: Missing l10n_parent field permission breaks page translation processClosed2019-11-13

Actions
#1

Updated by Georg Ringer over 1 year ago

  • Status changed from New to Closed

Thanks for creating the issue. This is well known and changed with #89672 as the exclude property has been removed from l10n_parent.

You can adopt this for your projects by removing the setting from tca as well.

I am closing this issue because it has been solved.

#2

Updated by Georg Ringer over 1 year ago

  • Related to Bug #89672: Missing l10n_parent field permission breaks page translation process added

Also available in: Atom PDF