Project

General

Profile

Actions

Bug #90677

closed

Renaming the main folder by a user destroys his file access

Added by Johannes Pieper almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2020-03-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a user renames the main folder in his or her file list, the filemount pointing to it no longer works. The user loses all access and cannot restore it.
When renaming folders, check if they are used as filemount or a non-admin user should be forbidden to rename his main folder.


Files

rename.png (21.3 KB) rename.png Johannes Pieper, 2020-03-09 10:30
Actions #1

Updated by Georg Ringer almost 4 years ago

Thanks for creating the issue. Sounds valid.
What do you think should be done if an editor renames a folder which is a mount for another editor? Is that just bad luck then?

Actions #2

Updated by Johannes Pieper almost 4 years ago

When renaming a directory in TYPO3, is it possible to check if it is used in a filemount? Then the filemount should be changed as well. This does not prevent problems caused by renaming outside TYPO3.

I can imagine that the prevention of top-level renaming by a user is sufficient as protection in most systems.

Actions #3

Updated by Christian Eßl almost 4 years ago

  • Category set to File Abstraction Layer (FAL)
Actions #4

Updated by Georg Ringer almost 4 years ago

So I wanted to fix that but I don't see any way to rename top folders, can you add a howto/Screenshots? Thx

Actions #5

Updated by Johannes Pieper almost 4 years ago

Filelist -> top right-hand corner

Actions #6

Updated by Georg Ringer almost 4 years ago

  • Status changed from New to Accepted
  • Target version set to next-patchlevel

thanks, learned something new ;)

Actions #7

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63674

Actions #8

Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63790

Actions #9

Updated by Christian Eßl almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF