Bug #90987

EmailFinisher use only plaintext Fluid template

Added by Markus Pircher over 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2020-04-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:
Remote Sprint

Description

If you add HTML to the email, initializeStandaloneView() is called twice, first for plaintext, second for html, but the templatePathAndFilename option is overwritten in the method, and then {@format} is no longer available, so the HTML part also us the plaintext template.

$this->options['templatePathAndFilename'] = strtr($this->options['templatePathAndFilename'], [
   '{@format}' => $format
]);


Related issues

Is duplicate of TYPO3 Core - Bug #93992: Forms: html emails get sent with plaintext template when using {@format} wildcard in "templatePathAndFilename" and not setting "useFluidEmail"Closed2021-04-27

Actions
#1

Updated by Markus Pircher over 1 year ago

  • Subject changed from EmailFinisher use only plantext Fluid template to EmailFinisher use only plaintext Fluid template
#2

Updated by Bjoern Jacob over 1 year ago

  • Sprint Focus set to Remote Sprint
#3

Updated by Paul Hansen over 1 year ago

  • Related to Feature #84849: Allow links and some HTML tags in label, description, static text, validators, and emailBody added
#4

Updated by Paul Hansen over 1 year ago

  • Related to deleted (Feature #84849: Allow links and some HTML tags in label, description, static text, validators, and emailBody)
#5

Updated by Bjoern Jacob 3 months ago

  • TYPO3 Version changed from 10 to 11

Have to check this. Seems valid.

#6

Updated by Andreas Häfner 3 months ago

  • Is duplicate of Bug #93992: Forms: html emails get sent with plaintext template when using {@format} wildcard in "templatePathAndFilename" and not setting "useFluidEmail" added
#7

Updated by Andreas Häfner 3 months ago

Is a duplicate of #93992

#8

Updated by Ralf Zimmermann 3 months ago

  • Status changed from New to Closed

Also available in: Atom PDF